const regex = /\.(\d+)\./g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\.(\\d+)\\.', 'g')
const str = `1. Place pastry on microwave safe plate.2. Heat on high for 3 seconds.3. Cool briefly before handling.`;
const subst = `.<br>$1.`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);