# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?<=^([^\\]+\\){6})/y\\/gi;t' <<< "C:\test\1\2\3\x\z\6\7\8"