using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=^([^\\]+\\){6})";
string substitution = @"y\\";
string input = @"C:\test\1\2\3\x\z\6\7\8";
RegexOptions options = RegexOptions.IgnoreCase;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}