const regex = new RegExp('(?<=^([^\\\\]+\\\\){6})', 'gi')
const str = `C:\\test\\1\\2\\3\\x\\z\\6\\7\\8`;
const subst = `y\\`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);