import re
regex = re.compile(r"(?<=^([^\\]+\\){6})", flags=re.IGNORECASE)
test_str = "C:\\test\\1\\2\\3\\x\\z\\6\\7\\8"
subst = "y\\\\"
result = regex.sub(subst, test_str)
if result:
print(result)