$re = '/(?<=^([^\\\\]+\\\\){6})/i';
$str = 'C:\\test\\1\\2\\3\\x\\z\\6\\7\\8';
$subst = "y\\";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;