import Foundation
let pattern = #"(?<=^([^\\]+\\){6})"#
let regex = try! NSRegularExpression(pattern: pattern, options: .caseInsensitive)
let testString = #"C:\test\1\2\3\x\z\6\7\8"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"y\\"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)