use strict;
my $str = 'C:\\test\\1\\2\\3\\x\\z\\6\\7\\8';
my $regex = qr/(?<=^([^\\]+\\){6})/ip;
my $subst = 'y\\\\';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";