#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?i)(?<=^([^\\]+\\){6})"
Local $sString = "C:\test\1\2\3\x\z\6\7\8"
Local $sSubst = "y\\"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)