$re = '/^(?=.{3,30}$)[A-Za-z0-9]+(?:\s[A-Za-z0-9]+)?$/m';
$str = 'Mark Twain
Michael Smith
New Name9012345678901234567890
New Name90123456789012345678901';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);