import re
regex = re.compile(r"^(?=.{3,30}$)[A-Za-z0-9]+(?:\s[A-Za-z0-9]+)?$", flags=re.MULTILINE)
test_str = ("Mark Twain\n"
"Michael Smith\n"
"New Name9012345678901234567890\n"
"New Name90123456789012345678901")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")