re = /^(?=.{3,30}$)[A-Za-z0-9]+(?:\s[A-Za-z0-9]+)?$/m
str = 'Mark Twain
Michael Smith
New Name9012345678901234567890
New Name90123456789012345678901'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end