# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/([a-zA-Z \\])|[^a-zA-Z \\]/\L\1/gm;t' <<< "abc Abc aBC cde123 def-ghi $?!123"