using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([a-zA-Z \\])|[^a-zA-Z \\]";
string substitution = @"\L\1";
string input = @"abc Abc aBC cde123 def-ghi $?!123";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}