const regex = /([a-zA-Z \\])|[^a-zA-Z \\]/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([a-zA-Z \\\\])|[^a-zA-Z \\\\]', 'gm')
const str = `abc Abc aBC cde123 def-ghi \$?!123`;
const subst = `\L\1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);