import Foundation
let pattern = #"([a-zA-Z \\])|[^a-zA-Z \\]"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"abc Abc aBC cde123 def-ghi $?!123"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\L\1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)