// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)([a-zA-Z \\])|[^a-zA-Z \\]").unwrap();
let string = "abc Abc aBC cde123 def-ghi $?!123";
let substitution = "\\L\\1";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}