package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([a-zA-Z \\])|[^a-zA-Z \\]`)
var str = `abc Abc aBC cde123 def-ghi $?!123`
var substitution = "\L\1"
fmt.Println(re.ReplaceAllString(str, substitution))
}