use strict;
my $str = 'abc Abc aBC cde123 def-ghi $?!123';
my $regex = qr/([a-zA-Z \\])|[^a-zA-Z \\]/mp;
my $subst = '\\L\\1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";