#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\b\d{5}\b"
Local $sString = "X test 1 test 1234 test; no output" & @CRLF & _
"V test 1 12345 test" & @CRLF & _
"X test 123456 test 12 test" & @CRLF & _
"V 12394 test" & @CRLF & _
"V 84725"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")