// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\b\d{5}\b").unwrap();
let string = "X test 1 test 1234 test; no output
V test 1 12345 test
X test 123456 test 12 test
V 12394 test
V 84725";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}