re = /\b\d{5}\b/
str = 'X test 1 test 1234 test; no output
V test 1 12345 test
X test 123456 test 12 test
V 12394 test
V 84725'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end