const regex = /\b\d{5}\b/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b\\d{5}\\b', 'g')
const str = `X test 1 test 1234 test; no output
V test 1 12345 test
X test 123456 test 12 test
V 12394 test
V 84725`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}