import Foundation
let pattern = #"\b\d{5}\b"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
X test 1 test 1234 test; no output
V test 1 12345 test
X test 123456 test 12 test
V 12394 test
V 84725
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)