package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\b\d{5}\b`)
var str = `X test 1 test 1234 test; no output
V test 1 12345 test
X test 123456 test 12 test
V 12394 test
V 84725`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}