import re
regex = re.compile(r"\b\d{5}\b")
test_str = ("X test 1 test 1234 test; no output\n"
"V test 1 12345 test\n"
"X test 123456 test 12 test\n"
"V 12394 test\n"
"V 84725")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")