#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?x)^ # 这是注释" & @CRLF & _
"hello # 这是注释" & @CRLF & _
"\ word # 若其中某个空格需要匹配, 需使用\转义" & @CRLF & _
"[ ]hi # 或者使用 [] 选中空格也可" & @CRLF & _
"$"
Local $sString = "hello word hi"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")