use strict;
my $str = 'hello word hi';
my $regex = qr/(?x)^ # 这是注释
hello # 这是注释
\ word # 若其中某个空格需要匹配, 需使用\转义
[ ]hi # 或者使用 [] 选中空格也可
$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}