// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?x)^ # 这是注释
hello # 这是注释
\ word # 若其中某个空格需要匹配, 需使用\转义
[ ]hi # 或者使用 [] 选中空格也可
$").unwrap();
let string = "hello word hi";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}