$re = '/(?x)^ # 这是注释
hello # 这是注释
\ word # 若其中某个空格需要匹配, 需使用\转义
[ ]hi # 或者使用 [] 选中空格也可
$/m';
$str = 'hello word hi';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);