import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?x)^ # 这是注释\n"
+ "hello # 这是注释\n"
+ "\\ word # 若其中某个空格需要匹配, 需使用\\转义\n"
+ "[ ]hi # 或者使用 [] 选中空格也可\n"
+ "$";
final String string = "hello word hi";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}