re = /(?x)^ # 这是注释
hello # 这是注释
\ word # 若其中某个空格需要匹配, 需使用\转义
[ ]hi # 或者使用 [] 选中空格也可
$/m
str = 'hello word hi'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end