using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?x)^ # 这是注释
hello # 这是注释
\ word # 若其中某个空格需要匹配, 需使用\转义
[ ]hi # 或者使用 [] 选中空 格也可
$";
string input = @"hello word hi";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}