package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?x)^ # 这是注释
hello # 这是注释
\ word # 若其中某个空格需要匹配, 需使用\转义
[ ]hi # 或者使用 [] 选中空格也可
$`)
var str = `hello word hi`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}