using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([a-z-0-9]*)\s*{((\s*[a-z-0-9]*\s*{.*?}\s*))}";
string input = @"Block1 {
block1child1 {
test1
}
block1child2 {
test2
}
block1child3 {
}
}
Block2 {
block2child1 {
}
block2child2 {
}
}";
RegexOptions options = RegexOptions.Singleline | RegexOptions.IgnoreCase | RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}