package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?sim)([a-z-0-9]*)\s*{((\s*[a-z-0-9]*\s*{.*?}\s*))}`)
var str = `Block1 {
block1child1 {
test1
}
block1child2 {
test2
}
block1child3 {
}
}
Block2 {
block2child1 {
}
block2child2 {
}
}`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}