const regex = /([a-z-0-9]*)\s*{((\s*[a-z-0-9]*\s*{.*?}\s*))}/simg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([a-z-0-9]*)\\s*{((\\s*[a-z-0-9]*\\s*{.*?}\\s*))}', 'simg')
const str = `Block1 {
block1child1 {
test1
}
block1child2 {
test2
}
block1child3 {
}
}
Block2 {
block2child1 {
}
block2child2 {
}
}`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}