$re = '/([a-z-0-9]*)\s*{((\s*[a-z-0-9]*\s*{.*?}\s*))}/sim';
$str = 'Block1 {
block1child1 {
test1
}
block1child2 {
test2
}
block1child3 {
}
}
Block2 {
block2child1 {
}
block2child2 {
}
}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);