re = /([a-z-0-9]*)\s*{((\s*[a-z-0-9]*\s*{.*?}\s*))}/im
str = 'Block1 {
block1child1 {
test1
}
block1child2 {
test2
}
block1child3 {
}
}
Block2 {
block2child1 {
}
block2child2 {
}
}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end