using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(\+455\ )(\d{3})(\d{1,3})(\d{1,3})?$";
string substitution = @"$1$2 $3 $4";
string input = @"+455 123123123
+455 1111
+455 11121
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}