use strict;
my $str = '+455 123123123
+455 1111
+455 11121
';
my $regex = qr/^(\+455\ )(\d{3})(\d{1,3})(\d{1,3})?$/mp;
my $subst = '$1$2 $3 $4';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";