#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\d{5}"
Local $sString = "5285 KEYES DR KALAMAZOO MI 49004 2613" & @CRLF & _
"PO BOX 35 COLFAX LA 71417 35" & @CRLF & _
"64938 MAGNOLIA LN APT B PINEVILLE LA 71360-9781"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")