import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\d{5}";
final String string = "5285 KEYES DR KALAMAZOO MI 49004 2613\n"
+ "PO BOX 35 COLFAX LA 71417 35\n"
+ "64938 MAGNOLIA LN APT B PINEVILLE LA 71360-9781";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}