re = /\d{5}/
str = '5285 KEYES DR KALAMAZOO MI 49004 2613
PO BOX 35 COLFAX LA 71417 35
64938 MAGNOLIA LN APT B PINEVILLE LA 71360-9781'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end