import Foundation
let pattern = #"\d{5}"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
5285 KEYES DR KALAMAZOO MI 49004 2613
PO BOX 35 COLFAX LA 71417 35
64938 MAGNOLIA LN APT B PINEVILLE LA 71360-9781
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)