package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\d{5}`)
var str = `5285 KEYES DR KALAMAZOO MI 49004 2613
PO BOX 35 COLFAX LA 71417 35
64938 MAGNOLIA LN APT B PINEVILLE LA 71360-9781`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}