using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\d{5}";
string input = @"5285 KEYES DR KALAMAZOO MI 49004 2613
PO BOX 35 COLFAX LA 71417 35
64938 MAGNOLIA LN APT B PINEVILLE LA 71360-9781";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}