$re = '/\d{5}/';
$str = '5285 KEYES DR KALAMAZOO MI 49004 2613
PO BOX 35 COLFAX LA 71417 35
64938 MAGNOLIA LN APT B PINEVILLE LA 71360-9781';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);