const regex = /\d{5}/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\d{5}', 'g')
const str = `5285 KEYES DR KALAMAZOO MI 49004 2613
PO BOX 35 COLFAX LA 71417 35
64938 MAGNOLIA LN APT B PINEVILLE LA 71360-9781`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}