# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\B@([^\B ]+)/<a href="profile.php?profile=$1">$0<\/a>/;t' <<< "test @hello test"